
eBooks: Exporting EPUB 
files from Adobe® InDesign®

The electronic publication (EPUB) format is an eBook file format that can be opened and read on 
any eBook reader that implements the standard. Using Adobe InDesign, you can export a 
document or book file directly to the EPUB format. When producing an InDesign document 
that will be exported as an EPUB file, there are a few things to keep in mind. This white paper 
provides tips and general guidelines for exporting well-formed and well-formatted EPUB files. It 
also explains how to export an EPUB file from InDesign.

To accomplish the tasks described in this white paper, you need the following:

• Adobe InDesign CS3 or CS4 software—Both versions of InDesign allow you to export to the 
EPUB format, but InDesign CS4 includes enhanced EPUB export features that simplify the 
conversion process.

• Adobe Digital Editions software—Adobe Digital Editions is a free, lightweight eBook reading 
application for Microsoft® Windows® and Mac OS X. You can use it to read and organize your 
eBook collection, as well as preview the EPUB files you export from InDesign.

Preparing a publication for export
Before you can export a high-quality EPUB file from InDesign, you must prepare the files for 
export.

Divide long documents into separate files
If you’re producing an eBook with multiple chapters or sections, create a separate InDesign 
document for each chapter and then combine all the documents together in an InDesign book 
file (File > New > Book). When you export the EPUB file, each chapter is converted into a 
separate XHTML file. This is especially important for long or complex eBooks, because the pages 
render faster in an eBook reader when an eBook is made up of several XHTML files.

Define the reading order of the eBook content
The EPUB format does not define page structure. During the conversion process, the relative 
position of all the design elements in the publication is discarded, and everything becomes 
linearized in the eBook. So when you convert an InDesign document to an EPUB file, all the 
content flows together in a single continuous stream.

To control the position of the content in the eBook, set up one text frame per page in your 
InDesign document, link all the text frames together as a single story, and then flow all the text 
and graphics within that story. This method ensures that everything is exported in the same 
order in which it flows in your InDesign document.

If you don’t place everything within a single story, InDesign exports the content in the order that 
it is arranged on the page—from left to right and then from the top down. You can control the 
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export order by extending or relocating the various frames on each page, but this method can be 
time-consuming. 

Anchor graphics and design elements
Graphics and other design elements, such as sidebars and callouts, need to be anchored within 
the main body of text so that they travel with the text when it reflows. An anchored object is part 
of a paragraph, so it always appears inline with that paragraph when viewed in an eBook reader.

To create an anchored object, select the object with the Selection tool and choose Edit > Cut. 
Then use the Type tool to position the cursor within the paragraph where you want the anchored 
object to appear and choose Edit > Paste. By default, the anchored object is placed inline with the 
paragraph. 

If you want to retain the original design of your publication, customize the position of each 
anchored object. However, although you can retain the basic design, the exact position of the 
anchored objects won’t be preserved in the EPUB file. Select the anchored object and choose 
Object > Anchored Object > Options. In the Anchored Object Options dialog box, choose 
Custom from the Position menu, and then adjust the options as necessary until the object is 
properly positioned. After clicking OK, you can drag the object around on the page to further 
customize its position if necessary.

For more information and tips on working with images, see the white paper “eBooks: Optimiz-
ing images for the EPUB file format” at www.adobe.com/products/indesign/epub/howto.

Apply paragraph and character styles
The most reliable way to ensure that your formatted text is preserved in the exported EPUB file is 
to apply paragraph and character styles to all the text in your document. InDesign uses the 
applied styles as the basis for generating the cascading style sheets (CSS), which determine how 
the text is formatted in the eBook.
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If you have used nested styles or GREP styles to format text in your InDesign CS4 document, the 
formatting they define is not preserved in the EPUB file. It is important to apply actual character 
styles to any text that is formatted with either a nested style or a GREP style.

Create a table of contents
A table of contents (TOC) is an essential element of any eBook because it allows a reader to 
quickly jump to specific sections. Two kinds of TOCs can be included in an eBook: a TOC 
located at the beginning of the eBook and one that functions as a navigation menu in an eBook 
reader.

If you have used the InDesign Table of Contents feature to generate a TOC at the beginning of 
the book, it is discarded in the exported EPUB file. To create a TOC that appears at the start of 
an eBook, manually insert the text for the entries and then turn each entry into a hyperlink that 
jumps to a specific section in the eBook. With InDesign CS4, you can use cross-references 
instead of hyperlinks to create the TOC. When you use cross-references, each TOC entry is 
generated from its destination text, so if the destination text is modified, you can easily update 
its corresponding TOC entry with the new text.

To create a TOC that functions as a navigation menu, set up a TOC style by choosing Layout > 
Table of Contents Styles. You can then specify the TOC style when you export the EPUB file, and 
InDesign uses it as the basis for generating the TOC. Note that not all eBook readers display a 
navigation menu in the same way. Adobe Digital Editions displays it in a panel to the left of the 
main content area, whereas other eBook readers display it in the form of a menu.

Add metadata
The EPUB format supports a number of metadata entries, such as the title, author, and publisher, 
that describe an eBook and make it searchable. InDesign can automatically export some 
metadata entries if you enter the information in the File Information dialog box, which you can 
access by choosing File > File Info. In the Description tab of the File Information dialog box, 
complete the following fields:

• Document Title—Enter the title of the publication.

• Author—Enter the author’s full name.

• Description—Enter a short description of the publication.

• Keywords—Enter the keywords that describe the publication’s subject category.

• Copyright Notice—Enter the copyright information for the publication.

The information is displayed in most eBook readers. None of the other metadata fields are 
exported to an EPUB file.
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Exporting an EPUB file
After the publication has been correctly set up and formatted, you are ready to export it to the 
EPUB format. To export a single InDesign document, choose File > Export for Digital Editions. 
To export an entire book file, choose Export Book For Digital Editions from the Book panel 
menu. In the Digital Editions Export Options dialog box, specify the following options.

General export options
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•	 Include Document Metadata—Select this option to export the metadata entered in the File 
Information dialog box. If you are exporting from a book file, make sure that the document 
containing the metadata is specified as the style source before you export the EPUB file. 
Otherwise, the metadata isn’t exported.

• Add Publisher Entry—This metadata field is not available in the File Information dialog box, 
so enter the publisher information here.

• Base For CSS Styles—Select which text formatting is used as the basis for generating the style 
sheets in the EPUB file. Choose Defined Styles if you consistently applied paragraph and 
character styles to all the text in the publication. The Defined Styles option generally gives you 
the most consistent and reliable results. Choose Local Formatting if the publication contains 
locally formatted text, such as bold and italicized words. Select Style Names Only to generate a 
CSS file with empty styles. You can then open the EPUB file and define the style sheets yourself.

• Bullets menu—If you used the InDesign Bullets and Numbering feature to create bulleted lists, 
select an option from this menu to specify how to export them. Select Map To Unordered Lists 
to convert the bulleted lists to HTML unordered lists, which are formatted with the <ul> and 
<li> tags. Select Convert To Text to convert them to HTML paragraphs that are formatted with 
the <p> tag. This option also converts all the bullet characters to actual text.

• Numbers menu—If you used the InDesign Bullets and Numbering feature to create numbered 
lists, select an option from this menu to specify how to export them. Select Map To Ordered 
Lists to convert the numbered lists to HTML ordered lists, which are formatted with the <ol> 
and <li> tags. The Map To Static Ordered Lists option also converts numbered lists into HTML 
ordered lists, but assigns a <value> attribute to each list item. The values are based on the 
current numbering of the lists in the InDesign document. Choose Convert To Text to convert 
the lists to HTML paragraphs. This option is useful when the lists use a numbering system 
other than simple numerals and you want to preserve them in the EPUB file.

• Include Embeddable Fonts—Select this option to embed all the fonts used into the EPUB file. 
InDesign exports OpenType® fonts and most TrueType fonts, but PostScript® fonts are not 
embedded. However, many eBook readers do not support embedded fonts. 

• View eBook After Exporting—Select this option to view the EPUB file after it has been 
exported. To view the eBook, you must have the free Adobe Digital Editions eBook reader 
installed. To download it, visit www.adobe.com/products/digitaleditions.
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Images export options

To specify how you want your images exported to the EPUB file, select Images on the left side of 
the dialog box. Select the options that fit your needs. For information about the image export 
options, see the white paper “eBooks: Optimizing images for the EPUB file format” at  
www.adobe.com/products/indesign/epub/howto.

Contents export options

To specify which format to use for the eBook and how to create the TOC, select Contents on the 
left side of the dialog box and set the following options.

• Format for EPUB Content—InDesign CS4 can export the EPUB content in either 
the XHTML format or DTBook format. The DTBook format is used for making 
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content accessible to people with disabilities, but it is not compatible with all eBook 
readers.

• Table of Contents—Select Include InDesign TOC Entries to generate a table of 
contents based on the TOC style that you choose from the TOC Style menu. Select 
Suppress Automatic Entries For Documents to prevent the InDesign document 
names from appearing in the generated TOC. If you are exporting from a book file, 
make sure that the document containing the TOC style is specified as the style 
source before you export the EPUB file. Otherwise, the TOC style will not be 
available in the TOC Style menu.

When you are ready to export the final EPUB file, click Export and then open the file with Adobe 
Digital Editions to view the results. If you find mistakes, return to the original InDesign 
document, make the necessary changes, and then export the EPUB file again.
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